Помощь Регистрация
Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 25 из 50
  1. #1
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности

    Помогите со сложными формулами в Excel...

    Нужно создать несколько сложных формул "ЕСЛИ", но не могу сообразить как их написать.
    Суть такова: есть искомые значения:
    52% 4 000
    55% 6 000
    60% 8 000
    65% 10 000
    75% 12 000
    Итог должен быть: если определенное значение < 52%, то 4000, если >=55%, то 6000 и т.д.
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  2. #2
    Федор
    Guest
    что-то вроде:
    =ЕСЛИ(B2<0,52;4000;ЕСЛИ(B2<0,55;6000;ЕСЛИ(B2<0,6;8000;ЕСЛИ(B2<0,65;10000;12000)))

  3. #3
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от Федор Посмотреть сообщение
    что-то вроде:
    =ЕСЛИ(B2<0,52;4000;ЕСЛИ(B2<0,55;6000;ЕСЛИ(B2<0,6;8000;ЕСЛИ(B2<0,65;10000;12000)))
    спасибо, почти получилось, только знаки равенства добавила еще)
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  4. #4
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    ага, ну или так:
    =ЕСЛИ(RC[-1]<52;4000;0)+ЕСЛИ(И(RC[-1]>=52;RC[-1]<55);6000;0)+...

  5. #5
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    нет, не получилось, он помежутки тогда не считает от 52 до 55 например и т.д.
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  6. #6
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    Итог должен быть: если определенное значение < 52%, то 4000, если >=55%, то 6000 и т.д.
    а если 53, то сколько?

  7. #7
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от mojo Посмотреть сообщение
    а если 53, то сколько?
    то 4000
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  8. #8
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    т.е. где-то должно быть так:
    если х<=52, то 4000, если х<= (от 53 до 55) то 6000 и т.д.
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  9. #9
    Moderator Аватар для Mazzay
    Регистрация
    21.02.2007
    Пол
    Пол: Мужской
    Авто
    BMW (BeMyWife)
    Сообщений
    56 617
    Благодарности
    Есть функция, которая находит значение (или следующее после него в случае отсутствия совпадений) в одном диапазоне (столбце) и возвращает соответствующее ему значение из другого диапазона. Название на память не помню. Доберусь до компа -- могу посмотреть.

  10. #10
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от Mazzay Посмотреть сообщение
    Есть функция, которая находит значение (или следующее после него в случае отсутствия совпадений) в одном диапазоне (столбце) и возвращает соответствующее ему значение из другого диапазона. Название на память не помню. Доберусь до компа -- могу посмотреть.
    посм.пжл.)
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  11. #11

    Регистрация
    14.10.2006
    Пол
    Пол: Мужской
    Авто
    LADA LARGUS люкс 7 мест
    Возраст
    34
    Сообщений
    220
    Благодарности
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    то 4000
    То есть 53 - это 4000
    А 51 это сколько?

  12. #12
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от TimonSP Посмотреть сообщение
    То есть 53 - это 4000
    А 51 это сколько?
    0
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  13. #13

    Регистрация
    14.10.2006
    Пол
    Пол: Мужской
    Авто
    LADA LARGUS люкс 7 мест
    Возраст
    34
    Сообщений
    220
    Благодарности
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    0
    Ну тогда формула из 2 поста, только суммы изменим и добавим ещё один ЕСЛИ:

    =ЕСЛИ(B2<0,52;0;ЕСЛИ(B2<0,55;4000;ЕСЛИ(B2<0,6;6000;ЕСЛИ(B2<0,65;8000;ЕСЛИ(B2<0,75;10000;12000))))
    Последний раз редактировалось support; 30.09.2011 в 16:19. Причина: Упс

  14. #14
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    а если 53, то сколько?
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    то 4000
    противоречит
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    т.е. где-то должно быть так:
    если х<=52, то 4000, если х<= (от 53 до 55) то 6000 и т.д.
    потому как по этой логике 6000

    так все заработало или нет? "нет, не получилось" к чьей формуле относилось?

  15. #15
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от mojo Посмотреть сообщение
    противоречит


    потому как по этой логике 6000

    так все заработало или нет? "нет, не получилось" к чьей формуле относилось?
    ой, да уше шарик за ролик уехал, если 53, то 4000
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  16. #16
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от TimonSP Посмотреть сообщение
    Ну тогда формула из 2 поста, только суммы изменим и добавим ещё один ЕСЛИ:

    =ЕСЛИ(B2<0,52;0;ЕСЛИ(B2<0,55;4000;ЕСЛИ(B2<0,6;6000;ЕСЛИ(B2<0,65;8000;ЕСЛИ(B2<0,75;10000;12000))))

    заработало!!! ток, вместо цифр ща ячейки посталю и посмотрю, что получилось, спс

    пс. все! все! уря! спс!!!
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  17. #17
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    если я правильно понял интервалы, то
    =ЕСЛИ(RC[-1]<52;0;0)+ЕСЛИ(И(RC[-1]>=52;RC[-1]<55);4000;0)+ЕСЛИ(И(RC[-1]>=55;RC[-1]<60);6000;0)+ЕСЛИ(И(RC[-1]>=60;RC[-1]<65);8000;0)+ЕСЛИ(И(RC[-1]>=65;RC[-1]<75);10000;0)+ЕСЛИ(RC[-1]>=75;12000;0)

  18. #18
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от Mazzay Посмотреть сообщение
    Есть функция, которая находит значение (или следующее после него в случае отсутствия совпадений) в одном диапазоне (столбце) и возвращает соответствующее ему значение из другого диапазона. Название на память не помню. Доберусь до компа -- могу посмотреть.
    это тоже понадобится для других таблиц, посм.пжл.
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  19. #19
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от mojo Посмотреть сообщение
    если я правильно понял интервалы, то
    =ЕСЛИ(RC[-1]<52;0;0)+ЕСЛИ(И(RC[-1]>=52;RC[-1]<55);4000;0)+ЕСЛИ(И(RC[-1]>=55;RC[-1]<60);6000;0)+ЕСЛИ(И(RC[-1]>=60;RC[-1]<65);8000;0)+ЕСЛИ(И(RC[-1]>=65;RC[-1]<75);10000;0)+ЕСЛИ(RC[-1]>=75;12000;0)
    попробовала и эту формулу - итог пишет 0, при 60%
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  20. #20
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    Цитата Сообщение от БелоСнежка ) Посмотреть сообщение
    попробовала и эту формулу - итог пишет 0, при 60%
    у меня пишет 8000

  21. #21

    Регистрация
    14.10.2006
    Пол
    Пол: Мужской
    Авто
    LADA LARGUS люкс 7 мест
    Возраст
    34
    Сообщений
    220
    Благодарности
    Цитата Сообщение от mojo Посмотреть сообщение
    у меня пишет 8000
    Это потому что у тебя расчёт на число 60, а не на 60% (0,6).

  22. #22
    Аватар для БелоСнежка )
    Регистрация
    29.09.2010
    Пол
    Пол: Женский
    Сообщений
    3 677
    Благодарности
    Цитата Сообщение от TimonSP Посмотреть сообщение
    Это потому что у тебя расчёт на число 60, а не на 60% (0,6).
    угу, тоже получилось
    У человека нет возможности всем делать добро, но у него есть возможность никому не причинять зла...©


  23. #23
    Moderator Аватар для Mazzay
    Регистрация
    21.02.2007
    Пол
    Пол: Мужской
    Авто
    BMW (BeMyWife)
    Сообщений
    56 617
    Благодарности
    См. вложения.

    В OpenOffice (или LibreOffice) Calc функция называется "LOOKUP".
    В MS Excel функция называется "ПРОСМОТР".
    Вложения Вложения

  24. #24
    Аватар для mojo
    Регистрация
    08.11.2006
    Сообщений
    1 698
    Благодарности
    вбивать значение в желтую ячейку, 2й способ - масштабируемое решение на любое число интервалов, главное не забыть добавить верхнюю границу (100 в примере)
    Вложения Вложения
    • Тип файла: xls 11.xls (33.0 Кб, Просмотров: 62)

  25. #25
    Moderator Аватар для Mazzay
    Регистрация
    21.02.2007
    Пол
    Пол: Мужской
    Авто
    BMW (BeMyWife)
    Сообщений
    56 617
    Благодарности
    Код:
    	A	B
    1	0%	0
    2	52%	4000
    3	55%	6000
    4	60%	8000
    5	65%	10000
    6	75%	12000
    ...
    9	Х	=ЕСЛИ(A9="";;ПРОСМОТР(A9;A1:A6;B1:B6))

Страница 1 из 2 12 ПоследняяПоследняя
Похожие темы
  1. Помогите со Сталкером! Не хочет сохранять игру(((
    от Ludmila в разделе Компьютеры, телефоны, игры, ПО, связь
    Ответов: 14
    Последнее сообщение: 31.01.2011, 19:09
  2. Помогите со звуком
    от Tormentor в разделе АвтоЗвук
    Ответов: 1
    Последнее сообщение: 31.07.2010, 14:00
  3. Ответов: 2
    Последнее сообщение: 20.04.2010, 07:08
  4. Помогите со звуком
    от Partizan в разделе АвтоЗвук
    Ответов: 19
    Последнее сообщение: 01.08.2009, 00:13
  5. Помогите со сваркой
    от alexxx в разделе Автомобильный
    Ответов: 1
    Последнее сообщение: 05.05.2004, 07:58
Ваши права
  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •