Помощь Регистрация
Показано с 1 по 8 из 8
  1. #1
    AG Team Аватар для sab322
    Регистрация
    22.11.2005
    Пол
    Пол: Мужской
    Авто
    VP&FF3
    Возраст
    33
    Сообщений
    13 110
    Благодарности

    формула в Exel

    Нужна формула(если таковая имеется): выборочное(по числу находящемуся в соседней ячейке) суммирование ячеек

    Например:
    если в ячейке В2 стоит определенное число, то соседняя ячейка"С2" суммируется с ячейкой "С... " (у которой "В..." -имеет тоже самое число)


  2. #2
    Аватар для dalex
    Регистрация
    15.02.2006
    Пол
    Пол: Мужской
    Авто
    Ford Fusion
    Возраст
    35
    Сообщений
    17 079
    Благодарности
    Цитата Сообщение от sab322 Посмотреть сообщение
    Нужна формула(если таковая имеется): выборочное(по числу находящемуся в соседней ячейке) суммирование ячеек

    Например:
    если в ячейке В2 стоит определенное число, то соседняя ячейка"С2" суммируется с ячейкой "С... " (у которой "В..." -имеет тоже самое число)

    Ну так сделай формулу, в которой будет условный переход

  3. #3
    AG Team Аватар для sab322
    Регистрация
    22.11.2005
    Пол
    Пол: Мужской
    Авто
    VP&FF3
    Возраст
    33
    Сообщений
    13 110
    Благодарности
    если я знал как

    по подробнее мона?

  4. #4
    Аватар для dalex
    Регистрация
    15.02.2006
    Пол
    Пол: Мужской
    Авто
    Ford Fusion
    Возраст
    35
    Сообщений
    17 079
    Благодарности
    Цитата Сообщение от sab322 Посмотреть сообщение
    если я знал как

    по подробнее мона?
    Хелп посмотри в экселе...

    ЕСЛИ

    См. также
    Возвращает одно значение, если заданное условие при вычислении дает значение ИСТИНА, и другое значение, если ЛОЖЬ.
    Функция ЕСЛИ используется при проверке условий для значений и формул.
    Синтаксис
    ЕСЛИ(лог_выражение;значение_если_истина;значение_если_ложь)
    Лог_выражение — это любое значение или выражение, принимающее значения ИСТИНА или ЛОЖЬ. Например, A10=100 — это логическое выражение; если значение в ячейке A10 равно 100, то выражение принимает значение ИСТИНА. В противном случае — ЛОЖЬ. Этот аргумент может быть использован в любом операторе сравнения.
    Значение_если_истина — это значение, которое возвращается, если лог_выражение равно ИСТИНА. Например, если этот аргумент — строка «В пределах бюджета» и лог_выражение равно ИСТИНА, тогда функция ЕСЛИ отобразит текст «В пределах бюджета». Если лог_выражение равно ИСТИНА, а значение_если_истина пусто, то возвращается значение 0. Чтобы отобразить слово ИСТИНА, необходимо использовать логическое значение ИСТИНА для этого аргумента. Значение_если_истина может быть формулой.
    Значение_если_ложь — это значение, которое возвращается, если лог_выражение равно ЛОЖЬ. Например, если этот аргумент — строка «Превышение бюджета» и лог_выражение равно ЛОЖЬ, то функция ЕСЛИ отобразит текст «Превышение бюджета». Если лог_выражение равно ЛОЖЬ, а значение_если_ложь опущено (то есть после значение_если_истина нет точки с запятой), то возвращается логическое значение ЛОЖЬ. Если лог_выражение равно ЛОЖЬ, а значение_если_ложь пусто (то есть после значение_если_истина стоит точка с запятой с последующей закрывающей скобкой), то возвращается значение 0. Значение_если_ложь может быть формулой.
    Заметки
    • До 7 функций ЕСЛИ могут быть вложены друг в друга в качестве значений аргументов значение_если_истина и значение_если_ложь для конструирования более сложных проверок. См. последний из приведенных ниже примеров.
    • Когда значения аргументов значение_если_истина и значение_если_ложь вычислены, функция ЕСЛИ возвращает полученное значение.
    • Если один из аргументов функции ЕСЛИ является массивом, при выполнении функции ЕСЛИ вычисляются все элементы массива.
    • Microsoft Excel предлагает дополнительные функции, которые можно применять для анализа данных с использованием условий. Например, для вычисления числа появлений текстовой строки или числа в диапазоне ячеек используйте функцию СЧЁТЕСЛИ. Для вычисления суммы значений, попадающих в интервал, заданный текстовой строкой или числами, используйте функцию СУММАЕСЛИ. Вычисление значений с использованием условия.
    Пример 1
    Чтобы этот пример проще было понять, скопируйте его на пустой лист.
    Инструкции
    1. Создайте пустую книгу или лист.
    2. Выделите пример в разделе справки. Не выделяйте заголовок строки или столбца.
      Выделение примера в справке.
    3. Нажмите сочетание клавиш CTRL+C
    4. На листе выделите ячейку A1 и нажмите сочетание клавиш CTRL+V.
    5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите сочетание клавиш CTRL+` (апостроф) или в меню Сервис укажите на пункт Зависимости формул и выберите режим Режим проверки формул.
    1 2 A Данные 50 Формула Описание (результат) =ЕСЛИ(A2<=100;"Внутри бюджета";"Вне бюджета") Если приведенное выше число меньше либо равно числу 100, формула отображает строку «В пределах бюджета». В противном случае — строку «Превышение бюджета» (В пределах бюджета) =ЕСЛИ(A2=100;СУММ(B5:B15);"") Если число равно 100, вычисляется сумма в диапазоне B5:B15. В противном случае возвращается пустой текст ("") () Пример 2
    Чтобы этот пример проще было понять, скопируйте его на пустой лист.
    Инструкции
    1. Создайте пустую книгу или лист.
    2. Выделите пример в разделе справки. Не выделяйте заголовок строки или столбца.
      Выделение примера в справке.
    3. Нажмите сочетание клавиш CTRL+C
    4. На листе выделите ячейку A1 и нажмите сочетание клавиш CTRL+V.
    5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите сочетание клавиш CTRL+` (апостроф) или в меню Сервис укажите на пункт Зависимости формул и выберите режим Режим проверки формул.
    1 2 3 4 A B Фактические расходы Предполагаемые расходы 1500 900 500 900 500 925 Формула Описание (результат) =ЕСЛИ(A2>B2;"Превышение бюджета";"OK") Проверяет первую строку на превышение бюджета (Превышение бюджета) =ЕСЛИ(A3>B3;"Превышение бюджета";"OK") Проверяет вторую строку на превышение бюджета (OK) Пример 3
    Чтобы этот пример проще было понять, скопируйте его на пустой лист.
    Инструкции
    1. Создайте пустую книгу или лист.
    2. Выделите пример в разделе справки. Не выделяйте заголовок строки или столбца.
      Выделение примера в справке.
    3. Нажмите сочетание клавиш CTRL+C
    4. На листе выделите ячейку A1 и нажмите сочетание клавиш CTRL+V.
    5. Чтобы переключиться между просмотром результатов и просмотром формул, возвращающих эти результаты, нажмите сочетание клавиш CTRL+` (апостроф) или в меню Сервис укажите на пункт Зависимости формул и выберите режим Режим проверки формул.
    1 2 3 4 A Балл 45 90 78 Формула Описание (результат) =ЕСЛИ(A2>89;"A";ЕСЛИ(A2>79;"B"; ЕСЛИ(A2>69;"C";ЕСЛИ(A2>59;"D";"F")))) Назначает буквенную категорию первому баллу (F) =ЕСЛИ(A3>89;"A";ЕСЛИ(A3>79;"B"; ЕСЛИ(A3>69;"C";ЕСЛИ(A3>59;"D";"F")))) Назначает буквенную категорию второму баллу (A) =ЕСЛИ(A4>89;"A";ЕСЛИ(A4>79;"B"; ЕСЛИ(A4>69;"C";ЕСЛИ(A4>59;"D";"F")))) Назначает буквенную категорию третьему баллу © В предыдущем примере второе предложение ЕСЛИ является в то же время аргументом значение_если_ложь для первого предложения ЕСЛИ. Аналогично, третье предложение ЕСЛИ является аргументом значение_если_ложь для второго предложения ЕСЛИ. Например, если первое лог_выражение (Среднее>89) имеет значение ИСТИНА, то возвращается значение "A". Если первое лог_выражение имеет значение ЛОЖЬ, то вычисляется второе предложение ЕСЛИ и так далее.
    Буквенные категории назначаются числам, используя следующую таблицу.
    Если балл равен Категория Больше 89 A От 80 до 89 B От 70 до 79 C От 60 до 69 D Меньше 60 F


    Таблицы съехали, но думаю поймёшь
    Последний раз редактировалось support; 10.11.2008 в 18:03.

  5. #5
    AG Team Аватар для sab322
    Регистрация
    22.11.2005
    Пол
    Пол: Мужской
    Авто
    VP&FF3
    Возраст
    33
    Сообщений
    13 110
    Благодарности
    да не эт я понял - методом тыка нашел))

    =ЕСЛИ(D=2;СУММ(C5:C150)) - вот работает(считает всю сумму всех ячеек "С", если хотя бы в одной ячейке "D" есть цифра 2

    мне немного другое надо: допустим в ячейках "D" стоят коды, а в "С" суммы,
    так мне нада по каждому коду получить отдельную сумму

  6. #6

    Регистрация
    14.10.2006
    Пол
    Пол: Мужской
    Авто
    LADA LARGUS люкс 7 мест
    Возраст
    33
    Сообщений
    220
    Благодарности
    Попробуй так =СУММЕСЛИ(D110;"=aaa";С1:С10).
    Тогда просуммируется столбец С, такой что в D лежит строка "aaa".

  7. #7
    AG Team Аватар для sab322
    Регистрация
    22.11.2005
    Пол
    Пол: Мужской
    Авто
    VP&FF3
    Возраст
    33
    Сообщений
    13 110
    Благодарности
    TimonSP пасиб за наводку, формула немного подругому выглядит))
    =СУММЕСЛИ(D110;2;C1:C10)

  8. #8
    Аватар для Stas_K
    Регистрация
    24.01.2006
    Пол
    Пол: Мужской
    Авто
    Chevrolet Cruze
    Возраст
    40
    Сообщений
    934
    Благодарности
    =СУММ(E1:СМЕЩ(E1;D2-1;0))
    E1 - первое значение в столбце, который будем суммировать
    D2 - ссылка на ячейку, содержащую количество строк вниз (число больше нуля) в столбце, который будем суммировать

    Вот.

Похожие темы
  1. Нужна формула для exel
    от CRAZY в разделе Компьютеры, телефоны, игры, ПО, связь
    Ответов: 11
    Последнее сообщение: 13.10.2011, 16:47
  2. Формула-1.
    от Anthrax в разделе Автомобильный
    Ответов: 446
    Последнее сообщение: 16.11.2007, 12:25
  3. Формула-1 2006
    от AseR в разделе Автомобильный
    Ответов: 183
    Последнее сообщение: 23.10.2006, 17:40
  4. Формула-1
    от Anthrax в разделе Автомобильный
    Ответов: 2
    Последнее сообщение: 26.08.2006, 13:17
  5. Ответов: 4
    Последнее сообщение: 12.11.2005, 20:03
Ваши права
  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •