Помощь Регистрация
Показано с 1 по 10 из 10
  1. #1
    Аватар для Nikita
    Регистрация
    19.12.2006
    Пол
    Пол: Мужской
    Возраст
    31
    Сообщений
    2 168
    Благодарности

    Кто хорошо знает Excel?

    Хочу для облегчения некоторых процессов на работе сделать таблицу, которая должна сама подставлять значения на основе фокусных ячеек. Например: есть прайс, где указаны артикулы и цены. Нужно, чтобы на другом листе при вводе артикула из прайса в одну ячейку, в другой автоматом проставлялась стоимость данного артикула из этого же прайса. Вот что-то никак не соображу как должна выглядеть формула. Или это вообще на макросах делать? В общем нужна помощь.

  2. #2
    Аватар для Эгоистка
    Регистрация
    21.01.2012
    Пол
    Пол: Женский
    Авто
    Hyundai Getz
    Сообщений
    1 568
    Благодарности
    Вам нужно,чтобы цифра,введенная на одной странице,отображалась на второй автоматом?

  3. #3
    Moderator Аватар для Mazzay
    Регистрация
    21.02.2007
    Пол
    Пол: Мужской
    Авто
    BMW (BeMyWife)
    Сообщений
    56 579
    Благодарности
    Это можно сделать, и у меня реализовано для подобных целей. На одном листе, грубо говоря, два столбца: артикул и цена. На другом листе, когда выбираем из выпадающего списка артикул (можно и руками вводить), в нужном поле появляется и цена.
    Увы, но названия формулы не помню, а доступ к этому своему файлу получу не раньше конца недели, скорее всего. И Excel'а под рукой нет.

  4. #4
    Аватар для Vaniok
    Регистрация
    11.02.2010
    Пол
    Пол: Мужской
    Авто
    Renault Logan
    Сообщений
    658
    Благодарности
    =ВПР($A1;Лист1!A$1:B$5;2;ЛОЖЬ)

    Лист 1.
    Столбец 1 - Артикулы.
    Столбец 2 - Цены.

    Лист 2 того же документа.
    Столбец 1 - сам вписываешь артикул руками.
    Столбец 2 - вставляешь эту формулу и протягиваешь вниз.

    Так?

  5. #5
    Cursed
    Guest
    Цитата Сообщение от Эгоистка Посмотреть сообщение
    Вам нужно,чтобы цифра,введенная на одной странице,отображалась на второй автоматом?

    Онвводит артикл на 2ой странице (но она так же имеется на 1ой), а рядом появляется ее стоимость (из общей информации 1ой страницы ).

    Зы. не проще ли отфильтровать 1ую страницу? Если не требуется создать целый список артиклов

  6. #6
    Аватар для Yup
    Регистрация
    04.04.2009
    Пол
    Пол: Мужской
    Авто
    Volvo S80
    Возраст
    42
    Сообщений
    3 686
    Благодарности
    Если правильно понял, то нужно как в примере?

    Пример.xls

  7. #7
    Аватар для Yup
    Регистрация
    04.04.2009
    Пол
    Пол: Мужской
    Авто
    Volvo S80
    Возраст
    42
    Сообщений
    3 686
    Благодарности
    Цитата Сообщение от Vaniok Посмотреть сообщение
    =ВПР($A1;Лист1!A$1:B$5;2;ЛОЖЬ)

    Лист 1.
    Столбец 1 - Артикулы.
    Столбец 2 - Цены.

    Лист 2 того же документа.
    Столбец 1 - сам вписываешь артикул руками.
    Столбец 2 - вставляешь эту формулу и протягиваешь вниз.

    Так?
    Ой, не увидел. В моем примере тоже самое...

  8. #8
    Аватар для Eric Knox
    Регистрация
    30.04.2007
    Пол
    Пол: Мужской
    Авто
    Rover 827; Соренто
    Сообщений
    3 761
    Благодарности
    Цитата Сообщение от Nikita Посмотреть сообщение
    Хочу для облегчения некоторых процессов на работе сделать таблицу, которая должна сама подставлять значения на основе фокусных ячеек. Например: есть прайс, где указаны артикулы и цены. Нужно, чтобы на другом листе при вводе артикула из прайса в одну ячейку, в другой автоматом проставлялась стоимость данного артикула из этого же прайса. Вот что-то никак не соображу как должна выглядеть формула. Или это вообще на макросах делать? В общем нужна помощь.
    Цамарским хлопцам нужна помощь Саратовских умников? Когда на новоселье позовешь? я тебе какую хошь таблицу состряпаю))
    "У каждого из нас есть свои машины времени. Те, что переносят нас в прошлое зовутся воспоминаниями, а те, что в будущее - мечтами"

  9. #9
    Аватар для Nikita
    Регистрация
    19.12.2006
    Пол
    Пол: Мужской
    Возраст
    31
    Сообщений
    2 168
    Благодарности
    Цитата Сообщение от Eric Knox Посмотреть сообщение
    Цамарским хлопцам нужна помощь Саратовских умников? Когда на новоселье позовешь? я тебе какую хошь таблицу состряпаю))
    Так приезжай)))

  10. #10
    Аватар для Nikita
    Регистрация
    19.12.2006
    Пол
    Пол: Мужской
    Возраст
    31
    Сообщений
    2 168
    Благодарности
    Всем большое спасибо, действительно ВПР - то, что и требовалось

Похожие темы
  1. Кто хорошо знает Битрикс?
    от Nega в разделе Компьютеры, телефоны, игры, ПО, связь
    Ответов: 2
    Последнее сообщение: 08.11.2012, 17:17
  2. Кто хорошо знает Excel?
    от Nikita в разделе Обо всём
    Ответов: 0
    Последнее сообщение: 01.10.2012, 14:20
  3. Саратовцы, кто хорошо знает маршруты городского транспорта?
    от Zatwornik в разделе Полезно. Интересно. Познавательно
    Ответов: 67
    Последнее сообщение: 01.09.2011, 09:58
  4. Кто хорошо знает Access? Есть вопрос
    от Пётр в разделе Компьютеры, телефоны, игры, ПО, связь
    Ответов: 4
    Последнее сообщение: 01.03.2010, 20:17
  5. Ответов: 7
    Последнее сообщение: 09.08.2004, 19:12
Ваши права
  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •